首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Elasticsearch

最新的 elk 不支持 java10 怎么办

  •  
  •   shayang888 · 2018-04-13 16:35:01 +08:00 · 3057 次点击
    这是一个创建于 370 天前的主题,其中的信息可能已经有所发展或是发生改变。

    6.2.3 的 elk,自己装的 java10,结果启动的时候报错,网上查了下 不支持 java10 怎么办

    14 回复  |  直到 2018-04-14 10:50:15 +08:00
        1
    Arcy   2018-04-13 16:37:44 +08:00
    不用 java 10 || 不用 elk || 等兼容
        2
    shayang888   2018-04-13 16:42:32 +08:00
    @Arcy 新版本出了你们不喜欢更新吗
        3
    ZSeptember   2018-04-13 16:57:46 +08:00
    docker
        4
    qwertty01   2018-04-13 17:05:20 +08:00
    不是我们不喜欢更新,是人家 ELK 不喜欢更新。

    话说 Java10 对开发人员只是新增了一个 var,其他的都可以忽略掉,更新这个版本干啥?
        5
    orangeade   2018-04-13 17:05:24 +08:00 via Android
    Java 10 不是 LTS 吧
        6
    neoblackcap   2018-04-13 17:22:55 +08:00
    sdkman 安装不同的 jdk,使用合适的 java 版本来运行你的 elk
        7
    hihipp   2018-04-13 17:32:27 +08:00
    java runtime 一个系统可以安装多个版本,修改一下 elk 启动时用到的 java runtime 路径就好了。
        8
    sagaxu   2018-04-13 20:02:39 +08:00 via Android
    瞎折腾,现在 8 是最靠谱的,下一个靠谱的版本是 11,等着吧
        9
    honeycomb   2018-04-13 23:19:49 +08:00 via Android
    @shayang888 现在 lts 相当于是 8,而且非 lts 的公开支持周期像 Fedora 一样才半年
        10
    akira   2018-04-13 23:34:31 +08:00
    不关心是不是最新,只关心是不是比较合适
        11
    SharkIng   2018-04-14 01:42:27 +08:00 via iPhone
    生产环境在我们公司最忌讳用最新版了
    elk 现在还用的是 4.x 版本
        12
    lihongjie0209   2018-04-14 08:15:22 +08:00
    为什么要升级 java10
        13
    cyspy   2018-04-14 09:11:51 +08:00 via Android
    Java 已经改成类似 win10 的更新模式了,Java8 是 LTS,装了 Java9 只是为了 jshell
        14
    LosLord   2018-04-14 10:50:15 +08:00 via Android
    @cyspy 更像 ubuntu 吧
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1392 人在线   最高记录 4385   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 17ms · UTC 17:24 · PVG 01:24 · LAX 10:24 · JFK 13:24
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1