首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
测试工具
SmokePing
IPv6 访问测试
V2EX  ›  宽带症候群

校园网 ipv6

  •  
  •   Strelizia · 66 天前用 Android 发布 · 1640 次点击
    这是一个创建于 66 天前的主题,其中的信息可能已经有所发展或是发生改变。

    参照这两个教程设置了 nat6 1.同济大学 Openwrt 路由器 ipv6 教程(新手导向) https://blog.csdn.net/u014436214/article/details/75691156 2.通过 openwrt 的 NAT6 转发,使后端设备获得 ipv6 网络 https://www.right.com.cn/forum/forum.php?mod=viewthread&tid=198647&highlight=ipv6&mobile=2

    用的是 openwrt 大雕 r9 路由器是友华 1200

    设置好之后就可以链接上 ipv6 站点了( 6v/蒲公英) 但是过大概 30 分钟,就与这些站点失去连接,重启路由器也不给群辉分配 v6 地址。电脑网络还是有 v6 地址,显示 v6 网络可用,但是无法打开这些站点。 在 v6 可用的时候,qb 挂种,在 pt 站上有多个 v4 地址,不知道为什么?

    网络状况:PPPOE 拨号(不拨号插上网线就有 v6 地址)

    20 回复  |  直到 2019-02-20 19:20:08 +08:00
        1
    Strelizia   66 天前 via Android
    求大佬指教 /v6 是 2001 开头的
        2
    zro   66 天前
    30 分钟后失联,你在路由器检测下 v6 还是否可用,如果可用可能是 NAT6 的问题。
        3
    Strelizia   66 天前 via Android
    @zro 我下课试一试
        4
    Strelizia   66 天前
    @zro
    v6 貌似不可用了
    https://imgchr.com/i/kgZy4I
        5
    zro   66 天前
    貌似?你直接在 OpenWRT 那网络诊断一下啊,还有你的 OP 版本多少?
        6
    Strelizia   66 天前
    @zro 是使用 OpenWRT 的网络诊断,显示无网络连接,我能打开 v4 网站,v6 不可以
    版本是大雕的 r9.1.1 源码
    https://imgchr.com/i/kgwAht
        7
    Strelizia   66 天前
    然后我就重启了,过了很久才重新连接上 v6,路由器给电脑分配了 v6,群辉没给,实测要重启群辉才能拿到 v6.
    而且这个 nat6 会弄出好多个 v6 地址(一般是 3 个)
        8
    zro   66 天前
    你在 OP tracert 之后,记住它第一跳的地址,断了之后,再去 Ping 或 Tracert 这个地址
        9
    Strelizia   65 天前 via Android
    @zro ping 全部丢包
    traceroute 1.425ms
        10
    Strelizia   65 天前 via Android
    重新拨号 wan 的 PPPOE 会和 wan6 的 DHCp 冲突,摸不着头脑
        11
    zro   65 天前
    你这种情况我是在 Windows 上遇到的,OP 倒没遇到过,你官网参考一下:
    https://openwrt.org/docs/guide-user/network/ipv6/ipv6.nat6
        12
    zro   65 天前
    @Strelizia #10 你把 PPPoE 和 Wan6 在 /etc/config/network 的配置发上来看看
        13
    Strelizia   65 天前
    @zro
    config interface 'wan'
    option ifname 'eth0.2'
    option proto 'pppoe'
    option username '账号'
    option password '密码'
    option ipv6 'auto'

    config device 'wan_dev'
    option name 'eth0.2'
    option macaddr 'ac:e2:d3:6b:c3:d6'

    config interface 'wan6'
    option proto 'dhcpv6'
    option reqaddress 'try'
    option reqprefix 'auto'
    option peerdns '0'
    option ifname 'eth0.2'
    option dns '240c::6666 240c::6644'
        14
    zro   65 天前
    @Strelizia #13
    config interface 'wan6'
    option ifname '@wan'
    其他 option 照旧。

    另外,忘了你的是教育网,可以有别的方法,不用 NAT6 的:
    修改 /etc/config/dhcp,

    config dhcp 'wan6'
    option interface 'wan'
    option ra 'relay'
    option master '1'
    option ignore '1'

    config dhcp 'lan'
    option interface 'lan'
    option ra 'relay'

    再修改 /etc/config/network:
    option ula_prefix 'XXXX' 此行删掉或者行头加#,保存后退出;

    最后 /etc/init.d/odhcpd restart,看看设备是否有原生 v6 地址,如果没有把 /etc/config/network 的 Lan 段配置发上来
        15
    zro   65 天前
    还要 /etc/init.d/network reload
        16
    Strelizia   65 天前
    @zro
    我重新刷写了固件,把 /etc/config/dhcp,network 修改后的网络信息是这样的。
    以太网适配器 以太网:

    连接特定的 DNS 后缀 . . . . . . . : lan
    IPv6 地址 . . . . . . . . . . . . : 2001:250:5401:600:b50d:e9b1:9cb:d219
    IPv6 地址 . . . . . . . . . . . . : dd73:92af:d63a::5cf
    IPv6 地址 . . . . . . . . . . . . : dd8c:e31a:e770::5cf
    IPv6 地址 . . . . . . . . . . . . : fd84:66be:23f8::5cf
    IPv6 地址 . . . . . . . . . . . . : fd84:66be:23f8:0:b50d:e9b1:9cb:d219
    IPv6 地址 . . . . . . . . . . . . : fd8c:e31a:e770::5cf
    临时 IPv6 地址. . . . . . . . . . : 2001:250:5401:600:1cff:8817:ad66:9136
    临时 IPv6 地址. . . . . . . . . . : fd84:66be:23f8:0:1cff:8817:ad66:9136
    本地链接 IPv6 地址. . . . . . . . : fe80::b50d:e9b1:9cb:d219%26
    IPv4 地址 . . . . . . . . . . . . : 192.168.5.240
    子网掩码 . . . . . . . . . . . . : 255.255.255.0
    默认网关. . . . . . . . . . . . . : fe80::aee2:d3ff:fe6b:c3d5%26
    192.168.5.1



    还是说,之前的操作( nat6 )要重复一遍再修改这两个文件。wan/wan6 冲突的问题没有了。
        17
    zro   65 天前
    应该可以了,有两个 2001 开头的 v6 地址就正常了,其他 fd,dd 开头的应该是之前带的,不应该有的,你电脑断开网线重新插上再看看还有没有这些地址。

    PS:几时让我连一下你们的教育网
        18
    Strelizia   65 天前
    @zro 这样操作还是不能上 v6 站点,我最后还是选择了 nat6
    话说这个是 relay?修改了 dns 服务器还是没办法建立连接( 2001:250:5401:601::1
    )第一跳应该就是网关吧,用那个方法(非 nat6 )无法 ping 通 /traceroute
    PS:我们学校的网贼垃圾 4mbps,你确定要连?
        19
    zro   65 天前
    你在#14 的 /etc/config/dhcp 的基础上加多两行 option ndp 'relay',lan 和 wan6 段各一行,再 /etc/init.d/odhcpd restart 试试。。

    PS:你们教育网 v6 不垃圾,也不限速吧?只是想看看六维有什么资源值得下的,偶尔用用下个种子什么的。
        20
    jousca   64 天前
    @Strelizia IPV6 还有 NAT ???
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3077 人在线   最高记录 5043   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 23ms · UTC 10:26 · PVG 18:26 · LAX 03:26 · JFK 06:26
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1