首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
vue.js
V2EX  ›  Vue.js

记一个大坑,如果 vue 编译提示安装 core-js,很有可能是这个错

  •  
  •   xjr1022 · 33 天前 · 1293 次点击
    这是一个创建于 33 天前的主题,其中的信息可能已经有所发展或是发生改变。
    WARNING: We noticed you're using the `useBuiltIns` option without declaring a core-js version. Currently, we assume version 2.x when no version is passed. Since this default version will likely change in future versions of Babel, we recommend explicitly setting the core-js version you are using via the `corejs` option.
    
    You should also be sure that the version you pass to the `corejs` option matches the version specified in your `package.json`'s `dependencies` section. If it doesn't, you need to run one of the following commands:
    
      npm install --save core-js@2    npm install --save core-js@3
      yarn add core-js@2              yarn add core-js@3
    

    我这几两天才学的 vue,用的 vue cli v3.6 版本,然后编译卡住不动,报这个错,因为当时刚好练习嵌套路由,以为是啥 module 和 router 模块起冲突,真的搞了我一下午,我 google 了半天,关于这个报错的相关数据很少,根本找不到答案,最后仔细看了下代码,就是<template>标签没有根 div,真的是血的教训</template>

    2 回复  |  直到 2019-03-25 00:12:52 +08:00
        1
    Sparetire   32 天前 via Android
    今天升级了项目依赖包,给我报了个这个 warn,不过好像没啥影响。。就没管他
    明天看看我代码里有没有这个问题。。
        2
    xjr1022   32 天前
    @Sparetire 如果你 npm run serve 没啥问题的话,那应该就没问题,这上面提示安装的 core-js 根本没用,浪费我一下午
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3077 人在线   最高记录 5043   ·  
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 63ms · UTC 10:31 · PVG 18:31 · LAX 03:31 · JFK 06:31
    ♥ Do have faith in what you're doing.
    沪ICP备16043287号-1