V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  yiluqingshen  ›  全部回复第 1 页 / 共 2 页
回复总数  30
1  2  
147 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
@qbqbqbqb

按你的方式调好了。

1-26 口分别配置 hybrid;
port hybrid pvid vlan 1-26
28 口配置:port hybrid vlan 101 to 128 untagged
port hybrid pvid vlan 128
148 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
补充:添加 PVID ,dis this 两个端口及 28 口
#1 口
[H3C-GigabitEthernet1/0/1]dis this
interface GigabitEthernet1/0/1
port link-type hybrid
port hybrid vlan 1 101 128 untagged
port hybrid pvid vlan 101
---------------------------------------------------------
#2 口

[H3C-GigabitEthernet1/0/2]dis this
interface GigabitEthernet1/0/1
port link-type hybrid
port hybrid vlan 1 102 128 untagged
port hybrid pvid vlan 102


--------------------------------------------------------
#28 口

[H3C-GigabitEthernet1/0/28]dis this
interface GigabitEthernet1/0/28
port link-type hybrid
port hybrid vlan 1 101 to 103 128 untagged
port hybrid pvid vlan 128
148 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
@qbqbqbqb
大佬,请问“其他口只允许自己的 PVID 和 28 口的 PVID ”;“28 口允许所有 vlan ”
是这样设置吗?是不是 28 口既要设置成 hybrid 接口类型并配置 PVID 且允许所有 vlan 通过。
欢迎纠错,谢谢。 以下以两个端口设置举例:

int g1/0/1

port link-type hybrid


port hybrid vlan 101 128 untagged

---------------------------------------------------------------

int g1/0/2

port link-type hybrid


port hybrid vlan 102 128 untagged

------------------------------------------------------------

28 口配置:


port link-type hybrid


port hybrid vlan 101 102 103 ……128 untagged
152 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
@defunct9 把它配置到默认的 VLAN1 可行吗? 28 口允许所有 VLAN 通过
152 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
@wuxiao2522 通过网心云 X86 服务器拨号,每条线路占用一个端口和拨一个账号,需要每个端口划分 VLAN 。
152 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
官方针对“配置基于 VLAN 的端口隔离”的配置文档有缺失,不够详细,看得云里雾里。
有会的朋友 给个具休配置命令吗?
二层。。。。。。我提交换机是二层,再次重申。。。。。
152 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
以下是官方文档的内容:


配置步骤
# 创建三个端口组 VLAN ,并将端口 Ethernet1/0/1 、Ethernet1/0/2 、Ethernet1/0/3 、Ethernet1/0/4 、Ethernet1/0/5 分别加入到三个端口组 VLAN 。

<Device> system-view

[Device] port-group-vlan 2 to 4

[Device] port-group-vlan 2 Ethernet 1/0/1 to Ethernet 1/0/2

[Device] port-group-vlan 2 Ethernet 1/0/6

[Device] port-group-vlan 3 Ethernet 1/0/3 to Ethernet 1/0/4

[Device] port-group-vlan 3 Ethernet 1/0/6

[Device] port-group-vlan 4 Ethernet 1/0/5

[Device] port-group-vlan 4 Ethernet 1/0/6

[Device] undo port-group-vlan 1 Ethernet 1/0/1 to Ethernet 1/0/5

# 显示端口组 VLAN 的信息。

<Device> display port-group-vlan all

Port-group-vlan ID: 1

Port-group-group Ports:

Ethernet1/0/6 Ethernet1/0/7 Ethernet1/0/8

Ethernet1/0/9 Ethernet1/0/10 Ethernet1/0/11

Ethernet1/0/12 Ethernet1/0/13 Ethernet1/0/14

Ethernet1/0/15 Ethernet1/0/16 Ethernet1/0/17

Ethernet1/0/18 Ethernet1/0/19 Ethernet1/0/20

Ethernet1/0/21 Ethernet1/0/22 Ethernet1/0/23

Ethernet1/0/24 GigabitEthernet1/0/25 GigabitEthernet1/0/26

Port-group-vlan ID: 2

Port-group-group Ports:

Ethernet1/0/1 Ethernet1/0/2 Ethernet1/0/6

Port-group-vlan ID: 3

Port-group-group Ports:

Ethernet1/0/3 Ethernet1/0/4 Ethernet1/0/6

Port-group-vlan ID: 4

Port-group-group Ports:

Ethernet1/0/5 Ethernet1/0/6
152 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
@wuxiao2522 谢谢朋友 ,如你所说我需要的应该是“基于 VLAN 的端口隔离”。
前面配置确实如 @Soo0 所说准备跑 PCDN 的,目前正在准宽带中,把这交换机来练练手,跟你们学习 1 下。
153 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
朋友们,看看 dis cu 配置信息,是什么问题,欢迎大佬分析指正。
153 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
sysname H3C
#
telnet server enable
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
lldp global enable
#
password-recovery enable
#
vlan 1
#
vlan 101 to 124
#
interface NULL0
#
interface Vlan-interface1
ip address dhcp-alloc
dhcp client identifier ascii 3cd2e5e72fb5-VLAN0001
#
interface GigabitEthernet1/0/1
port access vlan 101
#
interface GigabitEthernet1/0/2
port access vlan 102
#
interface GigabitEthernet1/0/3
port access vlan 103
#
interface GigabitEthernet1/0/4
port access vlan 104
#
interface GigabitEthernet1/0/5
port access vlan 105
#
interface GigabitEthernet1/0/6
port access vlan 106
#
interface GigabitEthernet1/0/7
port access vlan 107
#
interface GigabitEthernet1/0/8
port access vlan 108
#
interface GigabitEthernet1/0/9
port access vlan 109
#
interface GigabitEthernet1/0/10
port access vlan 110
#
interface GigabitEthernet1/0/11
port access vlan 111
#
interface GigabitEthernet1/0/12
port access vlan 112
#
interface GigabitEthernet1/0/13
port access vlan 113
#
interface GigabitEthernet1/0/14
port access vlan 114
#
interface GigabitEthernet1/0/15
port access vlan 115
#
interface GigabitEthernet1/0/16
port access vlan 116
#
interface GigabitEthernet1/0/17
port access vlan 117
#
interface GigabitEthernet1/0/18
port access vlan 118
#
interface GigabitEthernet1/0/19
port access vlan 119
#
interface GigabitEthernet1/0/20
port access vlan 120
#
interface GigabitEthernet1/0/21
port access vlan 121
#
interface GigabitEthernet1/0/22
port access vlan 122
#
interface GigabitEthernet1/0/23
port access vlan 123
#
interface GigabitEthernet1/0/24
port access vlan 124
#
interface GigabitEthernet1/0/25
#
interface GigabitEthernet1/0/26
#
interface GigabitEthernet1/0/27
#
interface GigabitEthernet1/0/28
port link-type trunk
port trunk permit vlan all
#
scheduler logfile size 16
#
line class aux
authentication-mode scheme
user-role network-admin
#
line class vty
authentication-mode scheme
user-role network-operator
#
line aux 0
user-role network-admin
#
line vty 0 63
user-role network-operator
#
snmp-agent
snmp-agent local-engineid 800063A2803CD2E5E72FC000000001
snmp-agent community write private
snmp-agent community read public
snmp-agent sys-info version all
#
domain system
#
domain default enable system
#
role name level-0
description Predefined level-0 role
#
role name level-1
description Predefined level-1 role
#
role name level-2
description Predefined level-2 role
#
role name level-3
description Predefined level-3 role
#
role name level-4
description Predefined level-4 role
#
role name level-5
description Predefined level-5 role
#
role name level-6
description Predefined level-6 role
#
role name level-7
description Predefined level-7 role
#
role name level-8
description Predefined level-8 role
#
role name level-9
description Predefined level-9 role
#
role name level-10
description Predefined level-10 role
#
role name level-11
description Predefined level-11 role
#
role name level-12
description Predefined level-12 role
#
role name level-13
description Predefined level-13 role
#
role name level-14
description Predefined level-14 role
#
user-group system
153 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
@Oohuo 意思是 28 口( trunk 口)连接上面家用 E2633 路由器,其它任一 1-24 口( access 口)连接电脑,这样我试过了 ,不能上网。
家用 E2633 不能划分 VLAN 的,TPLINK 的 802.1Q 为什么可以,1-7 口分别划分 VLAN ,几个口分别设置 PVID 可以上网的,也试过了。
机制应该类似,但是这台华三不太会弄了,
153 天前
回复了 yiluqingshen 创建的主题 宽带症候群 二层交换机配置无法上网的问题
@youdoit 路由器是装宽带 送的路由器(中兴 E2633 ),网关是 192.168.52.1 ,这台 2 层交换机怎么配置,二层交换机好像不能获取 DHCP 吧?
@youdoit
交换机显示信息,应该没错吧


[H3C]dis vlan 101
VLAN ID: 101
VLAN type: Static
Route interface: Not configured
Description: VLAN 0101
Name: VLAN 0101
Tagged ports: None
Untagged ports:
GigabitEthernet1/0/1
[H3C]dis vlan 102
VLAN ID: 102
VLAN type: Static
Route interface: Not configured
Description: VLAN 0102
Name: VLAN 0102
Tagged ports: None
Untagged ports:
GigabitEthernet1/0/2
@youdoit 哥们,学了带皮毛,我只能配置到退休了。我这样配置
system-view
vlan 101
quit
---------------------------------------------------------------------
interface GigabitEthernet1/0/1
port link-type access
port access vlan 101

此处省略 N 个端口。。。。。。。。。。。

---------------------------------------------------------------------
28 口这样设置:
interface GigabitEthernet1/0/28
port link-type trunk
port trunk permit vlan all


---------------------------------------------------------------------
这样对了吗?
28 口 trunk 是放行所有带标签 VLAN
@youdoit 交换机目前是空配置啊。。。

******************************************************************************
* Copyright (c) 2004-2020 New H3C Technologies Co., Ltd. All rights reserved.*
* Without the owner's prior written consent, *
* no decompiling or reverse-engineering shall be allowed. *
******************************************************************************

<H3C>%Jan 2 04:11:09:841 2013 H3C SHELL/5/SHELL_LOGIN: admin logged in from aux 0.

<H3C>dis cu
#
version 7.1.070, Release 6318P01
#
sysname H3C
#
telnet server enable
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 1
#
lldp global enable
#
password-recovery enable
#
vlan 1
#
interface NULL0
#
interface Vlan-interface1
ip address 192.168.1.254 255.255.255.0
dhcp client identifier ascii 3cd2e5e72fb5-VLAN0001
#
interface GigabitEthernet1/0/1
#
interface GigabitEthernet1/0/2
#
interface GigabitEthernet1/0/3
#
interface GigabitEthernet1/0/4
#
interface GigabitEthernet1/0/5
#
interface GigabitEthernet1/0/6
#
interface GigabitEthernet1/0/7
#
interface GigabitEthernet1/0/8
#
interface GigabitEthernet1/0/9
#
interface GigabitEthernet1/0/10
#
interface GigabitEthernet1/0/11
#
interface GigabitEthernet1/0/12
#
interface GigabitEthernet1/0/13
#
interface GigabitEthernet1/0/14
#
interface GigabitEthernet1/0/15
#
interface GigabitEthernet1/0/16
#
interface GigabitEthernet1/0/17
#
interface GigabitEthernet1/0/18
#
interface GigabitEthernet1/0/19
#
interface GigabitEthernet1/0/20
#
interface GigabitEthernet1/0/21
#
interface GigabitEthernet1/0/22
#
interface GigabitEthernet1/0/23
#
interface GigabitEthernet1/0/24
#
interface GigabitEthernet1/0/25
#
interface GigabitEthernet1/0/26
#
interface GigabitEthernet1/0/27
#
interface GigabitEthernet1/0/28
#
scheduler logfile size 16
#
line class aux
authentication-mode scheme
user-role network-admin
#
line class vty
authentication-mode scheme
user-role network-operator
#
line aux 0
user-role network-admin
#
line vty 0 63
user-role network-operator
@TenRice "![h3c]( https://imgur.com/dy2HoOr)"
大佬这个图片打不开,Excel 能打开,拼接命令是&吗?
@youdoit “不理解你的 ip 地址是用来管理还是配置到端口上”,管理口已经配置好,是配置到每个端口上,
比如说第一个端口 vlan101 192.168.101.1 ;
第二个端口: vlan102 192.168.102.1;
.................... 以此类推到 24 口。
大佬能贴个代码吗?
@youdoit 兄滴, 能教个方法吗?主要不会才觉得难。
@TESTFLIGHT2021 大佬,不会写批处理文件,怎么写?
@TenRice 大佬有方法或教程吗?不太会哦,1 台每个接口都一条条配置得配置到退休了。
1  2  
关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   2927 人在线   最高记录 6679   ·     Select Language
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.5 · 23ms · UTC 12:48 · PVG 20:48 · LAX 05:48 · JFK 08:48
Developed with CodeLauncher
♥ Do have faith in what you're doing.