首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
V2EX  ›  Linux

Ubuntu 安装 Storm 组件 JZMQ 时出错

  •  
  •   buptlee · 2014-03-03 14:19:05 +08:00 · 2917 次点击
    这是一个创建于 2106 天前的主题,其中的信息可能已经有所发展或是发生改变。
    为了安装Storm,其中一个组件JZMQ时,执行了./autogen.sh ./configure,出现以下错误。有经验的同学们帮我解答一下把,谢谢啦。
    checking how to hardcode library paths into programs... immediate
    ./configure: line 15263: syntax error near unexpected token `newline'
    ./configure: line 15263: ` PKG_CHECK_MODULES('
    1 回复  |  直到 1970-01-01 08:00:00 +08:00
        1
    buptlee   2014-03-03 17:10:58 +08:00
    折腾一下午,总算解决了。把解决方法写出来分享一下。
    由于jzmq在编译的过程中需要调用 PKG_CHECK_MODULES() 宏(Macro),这个Macro是pkg-config和Autoconf/Automake/aclocal交互的主要接口。jzmq.pkg.m4应该要存放的位置是/usr/share中。这个关系到autoconf和pkg-config的之间通过CALL PKG_CHECK_MODULES宏来检查给定依赖包是否存在。解决方法:
    sudo cp /usr/share/aclocal/pkg.m4 /usr/local/share/aclocal-1.14/
    然后还需要重新./autogen.sh使其生效,否则还是编译不过。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4250 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 01:43 · PVG 09:43 · LAX 17:43 · JFK 20:43
    ♥ Do have faith in what you're doing.