V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
cokar
V2EX  ›  浏览器

2024 年还有必要兼容 IE 浏览器吗?

  •  
  •   cokar · 45 天前 · 3095 次点击
    这是一个创建于 45 天前的主题,其中的信息可能已经有所发展或是发生改变。

    最近打算开发一款 CMS ,纠结使用 bootstrap 版本,我看同类型的 cms 后台很多还在使用 bootstrap3.x 版本,纠结中。

    后台到无所谓,提醒用 edge 或 chrome 浏览器就行。但是前端还是有点担心,有没有比较新的 IE 占比数据,现在还有必要去兼容 IE 吗?

    25 条回复    2024-04-12 13:35:39 +08:00
    yin1999
        1
    yin1999  
       45 天前   ❤️ 1
    https://caniuse.com/usage-table 不过可能不是太准
    ModerRAS
        2
    ModerRAS  
       45 天前
    看你面向的用户是啥,要是政企居多还是要适配的,毕竟还有大量的 win7 用户,当然不适配也不是很大的问题。相对来说你需要在意的是不要用太新的 chrome 特性,毕竟新版 chrome 已经不兼容 win7 了。
    to c 随意,直接看主流的占比就行。
    wu67
        3
    wu67  
       45 天前
    看你的最终用户群体.
    就像上面说的, 政企用户你要考虑支持.
    像我们公司做外贸的, 就直接奔着最新特性去了, 就突出一个狂放, 主要适配 Chrome, 其他浏览器等报 bug 再修改适配.
    protoss97
        4
    protoss97  
       45 天前   ❤️ 1
    完全没必要,现在 IE 用的人几乎为 0 ,政企客户也一样,他们都用 360 搜狗之类的浏览器
    caomu
        5
    caomu  
       45 天前 via Android
    政企也没必要,很多新系统直接在首页挂一个谷歌或者 360 浏览器的下载链接。除非是老系统改造,否则新系统没人会想不开去适配 ie 了。
    caomu
        6
    caomu  
       45 天前 via Android   ❤️ 1
    反倒是现在很多政企开始推信创/安可改造,越来越多 linux 核心的国产系统和 chromium 核心的浏览器。
    geekvcn
        7
    geekvcn  
       45 天前
    2024 年的新项目还支持 IE ,除非你用 IE 的客户能给你提供巨大的价值,否则完全不考虑。
    wzbrbj
        8
    wzbrbj  
       45 天前
    什么是 IE?没听过,政企就不需要新特性?什么年代了都
    gerefoxing
        9
    gerefoxing  
       45 天前
    政企客户他们都都不用了
    way2explore2
        10
    way2explore2  
       45 天前 via Android
    没有必要
    6F321i77Df1W0Zka
        11
    6F321i77Df1W0Zka  
       45 天前
    别为难自己
    mandex
        12
    mandex  
       45 天前
    不兼容 IE ,我都是加个这个提示
    ```html
    <!--[if IE]>
    <p class="browsehappy"
    style="position: absolute; width: 100%; height: 100px; top: 0; left:0; z-index: 999999; background-color: #d9aa7a; text-align: center; line-height: 100px;">
    You are using an <strong>outdated</strong> browser. Please <a
    href="https://browsehappy.com/" rel="noopener noreferrer">upgrade your browser</a> to improve your experience.</p>
    <![endif]-->
    ```
    piecezzz
        13
    piecezzz  
       45 天前
    面向对象编程啊
    jydeng
        14
    jydeng  
       45 天前
    看你的目标用户,给钱 IE6 也可以兼容
    Baymaxbowen
        15
    Baymaxbowen  
       45 天前
    我们搞信创都没要求要 ie 了,大部分都是 360
    boringwheat
        16
    boringwheat  
       45 天前
    完全没必要
    qiyilai
        17
    qiyilai  
       45 天前
    政企也不用了,除非是老系统维护
    clue
        18
    clue  
       45 天前
    主流的都不再支持 IE 了, 至少也是 Edge 起步, 除非你的客户特殊
    kinboy
        19
    kinboy  
       45 天前
    政企都在更换成国产操作系统了,麒麟 OS 了解一下,都是 Chromium 的
    angryfish
        20
    angryfish  
       45 天前
    不需要,政企也不需要。直接提示使用 360 浏览器就行了。
    cokar
        21
    cokar  
    OP
       45 天前 via Android   ❤️ 1
    谢谢大家,我决定不考虑 IE 了,直接用 bootstrap5
    sjhhjx0122
        22
    sjhhjx0122  
       45 天前
    政企都是什么国产化系统,全都是 chromium 套壳不会有 ie 的
    tlerbao
        23
    tlerbao  
       45 天前
    六七年前就开始只管 Chrome 了
    DOLLOR
        24
    DOLLOR  
       44 天前
    realJamespond
        25
    realJamespond  
       44 天前
    搞 ie 就用 jsp php+jq 这些吧
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   2489 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 25ms · UTC 12:11 · PVG 20:11 · LAX 05:11 · JFK 08:11
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.