首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
V2EX  ›  问与答

为嘛 wordpress 的编辑器不支持 Markdown?有哪个插件的兼容性最好?

  •  
  •   atao · 2014-07-28 09:52:22 +08:00 · 4356 次点击
    这是一个创建于 1934 天前的主题,其中的信息可能已经有所发展或是发生改变。
    8 回复  |  直到 2014-07-29 09:48:06 +08:00
        1
    laomo   2014-07-28 10:10:31 +08:00
    插件倒是有,其实问题在于,做到老文章和新文章的兼容处理,也就是存库的到底是md格式还是转完html格式。以前尝试过,已放弃。转 Octopress 和 Jekyll Bootstrap 了,不过都是静态的

    http://lmbj.net/blog/wordpress-support-markdown/
        2
    laomo   2014-07-28 10:13:48 +08:00
    另外,其实好多写微信公众号的也是用markdown写的,微信也不支持markdown。可以选一个合手的编辑器,转换完以后复制粘贴。。
        3
    babytomas   2014-07-28 10:28:18 +08:00
    为什么不尝试一下 typecho ?
        4
    andyliu   2014-07-28 10:35:29 +08:00
    ghost欢迎你
        5
    koy1619   2014-07-28 10:53:26 +08:00
    wordpress.com已经支持markdown了,估计wordpress.org也快了!当然你也可以使用WP-Markdown这个插件,效果一般,能满足最基本的markdown语法!
        6
    hjc4869   2014-07-28 11:25:43 +08:00
    同@andyliu 喜欢Markdown就用Ghost吧。
        7
    yangzh   2014-07-28 11:40:17 +08:00   ♥ 1
    http://jetpack.me/

    jetpack 是 wordpress 团队官方出的插件,把 @koy1619 说的很多 wordpress.com 的功能作为插件在 wordpress 自安装版实现了。其中有 markdown 功能模块。
        8
    atao   2014-07-29 09:48:06 +08:00
    我也是考虑过迁移到其他平台,不过近期实在没时间折腾,而突然喜欢上Markdown,插件效果的确不行,先凑合着用一段时间再看如何迁移。
    话说wordpress总是喜欢用Google开源字体,而google全面被封,每次升级都得折腾下这个问题的确很不爽。
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1011 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 21ms · UTC 19:35 · PVG 03:35 · LAX 11:35 · JFK 14:35
    ♥ Do have faith in what you're doing.