首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
V2EX  ›  问与答

ruby 貌似没有 Python 的版本分裂问题?

  •  
  •   strider · 2014-08-27 22:54:22 +08:00 · 2783 次点击
    这是一个创建于 1818 天前的主题,其中的信息可能已经有所发展或是发生改变。
    还没学过ruby,但学过python,现在python2和3就是两个分裂的版本了,版本前后不兼容没关系,但很多库都固守在python2,不愿意往新版本迁移。
    ruby貌似没有这个问题,大家都喜欢直接用最新的,是这样的吧?
    7 回复  |  直到 2014-08-28 12:13:00 +08:00
        1
    lichao   2014-08-27 23:16:46 +08:00 via iPhone
    Python 没用过。
    Ruby 新项目肯定上最新版。
        2
    whtsky   2014-08-28 01:38:25 +08:00 via iPhone
    是。
    但现在仍不支持 Python 3 的库不太多吧?
        3
    skybr   2014-08-28 06:49:44 +08:00
    不是, ruby变动比较大的是1.8到1.9, 花的年数也不少, 有部分甚至是直接从1.8过度到2.0. 而且拉升条件很多, 1.8完全放弃维护, REE也基本放弃, 性能提升(主要是2.0)比较大, 在ruby社区占比重的Rails在4.0放弃1.8支持.
        4
    fwee   2014-08-28 09:43:59 +08:00
    是,而且现在1.9, 2.0, 2.1区别都不是很大
        5
    Owenjia   2014-08-28 09:48:43 +08:00 via Android
    很多库都固守在 2.x,比较好奇具体是有哪些~~~
        7
    caoyue   2014-08-28 12:13:00 +08:00
    猜测:
    因为用 Python 的不都是做 Web 的吧
    但是 Rails 升级的话,大部分用 Ruby 的就跟着升级了
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   821 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 21ms · UTC 20:39 · PVG 04:39 · LAX 13:39 · JFK 16:39
    ♥ Do have faith in what you're doing.