首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
eoo
V2EX  ›  服务器

求助帮忙,有关 window 服务器下编译 so 文件的事!

  •  
  •   eoo · 2018-03-27 15:41:55 +08:00 · 1690 次点击
    这是一个创建于 672 天前的主题,其中的信息可能已经有所发展或是发生改变。

    问题是这样的,老板想要接入微信小程序,但是要接入就需要上 https,协议还不能低于 TLSv1.2。

    但是老板用的是 win 的一键集成环境 老版的 phpstudy2014 集成环境 里面提供的是 openssl0.9

    要支持 TLSv1.2 需要 openssl 1.0.1+ 版本,

    可我不会在 win 下的动态库编译操作,后缀是 so 的文件(不解的是 so 不是 linux 下的动态库吗? 怎么在 win 上也能用?) 的 的动态库

    哪位大神帮忙解决一下。

    KomeijiSatori
        1
    KomeijiSatori   2018-03-27 17:04:25 +08:00 via iPhone
    虚拟机
    eoo
        2
    eoo   2018-03-27 17:19:44 +08:00
    @KomeijiSatori 求帮助啊 有大红包啊!!!!!!!!!!
    eoo
        3
    eoo   2018-03-27 17:19:58 +08:00
    @KomeijiSatori 怎么解决?
    P0P
        4
    P0P   2018-03-27 20:40:10 +08:00
    前台使用新版本 nginx 反代一下就可以了
    eoo
        5
    eoo   2018-03-28 08:37:55 +08:00 via Android
    @P0P 算了,老板打算换环境了!
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1586 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 45ms · UTC 16:42 · PVG 00:42 · LAX 08:42 · JFK 11:42
    ♥ Do have faith in what you're doing.