首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Distributions
Ubuntu
Fedora
CentOS
中文资源站
网易开源镜像站
Coding
V2EX  ›  Linux

安装 openssl1.1.1.a 运行 openssl version 报错 openssl: error while loading shared libraries: libssl.so.1.1: file too short

  •  
  •   aruisi · 359 天前 · 1417 次点击
    这是一个创建于 359 天前的主题,其中的信息可能已经有所发展或是发生改变。
    编译完成后软链
    ln -s /usr/local/openssl/lib/libssl.so.1.1 /usr/lib64/libssl.so.1.1
    ln -s /usr/local/openssl/lib/libcrypto.so.1.1 /usr/lib64/libcrypto.so.1.1

    总是报错 openssl: error while loading shared libraries: libssl.so.1.1: file too short 是什么原因呢?求解
    2 回复  |  直到 2018-12-18 08:42:53 +08:00
        1
    iwtbauh   358 天前 via Android   ♥ 1
    $ LD_DEBUG=all openssl
        2
    Nitroethane   358 天前 via Android   ♥ 1
    应该是动态链接库没有链接正确。用 strace 跟踪一下或者 ldd 命令看下用到的动态链接库应该能发现问题
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3168 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 22ms · UTC 10:42 · PVG 18:42 · LAX 02:42 · JFK 05:42
    ♥ Do have faith in what you're doing.