首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  Apple

10.15 的 sidecar 功能没法打开吗

  •  
  •   arony · 76 天前 · 4146 次点击
    这是一个创建于 76 天前的主题,其中的信息可能已经有所发展或是发生改变。

    mba2013 10.15 ipad-6 10.13 在 mac 中找不到设置 搜索后发现有一个隐藏设置项 sidecar 但是打开提示该面板此时不可用

    41 回复  |  直到 2019-06-19 08:46:48 +08:00
        1
    minamike   76 天前 via iPhone
    我 2014 版的 mac 也是
    是不是要带 T2 处理器的才可以
    ( PS:sidecar 不给用就算了,结果升级后连 duet display 都挂了🙃
        2
    sobigfish   76 天前
    Reddit 上一篇文章说是要蓝牙 5.0 的 Mac 才行,同打不开,
    sidecar 设置里有个 sidecarPrefCheck 应该是检测功能的,谁能破解一波到底是要求什么
        3
    laixuan   76 天前
    第一代 iPad Pro 已悲剧(蓝牙版本 4 )。没有反应无法连接
    现在目测 mac + iPad 都得是蓝牙 5.0 才行
        4
    winddweb   76 天前 via iPad
    mbp2016 + iPad 10.5 可以用
        5
    wwwaaa   76 天前
    sidecar 只能用在 mac 上吗? win 的是不是不能用啊?
        6
    ys746663912   76 天前
    MacBook Pro (Retina, 15-inch, Late 2013)+iPad pro 一代,也不行.该面板此时不可用.
        7
    suith27   76 天前
    我记得说有线也可以连接呀,你们有 Mac 和 iPad 要不再试试?
        9
    arony   76 天前
    呃 那我的 iPad 2018 不行了么
        10
    minamike   76 天前 via iPhone
    @hguandl
    估计是根据识别电脑年代型号来判断的
    你的黑果是识别为哪年的 Mac 的
        11
    ys746663912   76 天前
        12
    hguandl   76 天前
    @minamike
    @ys746663912

    我直接搜索打开也是这样,其实打开方式不是这样的。

    首先让 macOS 和 iPad 连接到同一个 WiFi,然后 macOS 右上角的 AirPlay 里面就会有 iPad 选项了,可以参考我之前的截图。

    (不让连续发外链,就是前面第二张图 5cf666438b64f90626.jpeg )

    连接后就会启动 Sidecar,然后设置界面里也会自动出现那个选项。
        13
    ech0x   76 天前
    可以啊,我都用过了
        14
    ech0x   76 天前
    @ech0x #13 而且我的 iPad 还是 Air 2 呢……
        15
    minamike   76 天前
    @ech0x 那么你的 mac 是哪年的呢
        16
    WildCat   76 天前
    MacBook Pro (Retina, 15-inch, Mid 2015)
    +
    iPad Pro 12' Gen 1

    Not working.
        17
    oIMOo   76 天前
    sidecar 需要 macOS 和 iPadOS 都升级么?
    还是只升级后者即可?
        18
    minamike   76 天前
    @hguandl 不行 我菜单栏上连 AirPlay 的图标都不显示 = =
        19
    oIMOo   76 天前
    @wwwaaa 走的是 airplay。
    我记得 win 上面有 airplay 相关的软件,你可以试试? (看具体协议版本了)
        20
    oIMOo   76 天前
    @minamike 你进显示设置看看有没有 airplay 可以勾选的显示器 (好像在显示设置的左下角?)
        21
    hguandl   76 天前
    @minamike 勾选上「设置-显示器-在菜单栏中显示镜像选项(可用时)」看看。

    我的黑果机型设置是 17 年的 iMac 5K。

    我觉得最重要的就是连接到同一个 Wi-Fi,同一个 Apple ID,也把蓝牙都打开。
        22
    20015jjw   76 天前 via Android
    羡慕敢用 beta 的大佬们
        23
    oIMOo   76 天前
    @hguandl 感觉和触发 Airdrop 的条件类似
        24
    catbaron   76 天前
        25
    wellwell   75 天前
    Macbook 2017 + iPad 2018 working.
        26
    arony   75 天前
    @oIMOo airdrop 貌似在我这边一直很稳定
    @laixuan 应该不是蓝牙 5.0 但是有可能 4.2 是标压,我的 mba 是 2013mid 蓝牙就是 4.0 的 所以可能就没法实现了
    黑果目前主力机 还不敢升级 10.15
        27
    zander   75 天前
    4.1 蓝牙的黑苹果郁闷了,
    MBP 是 2017 的应该是 5.0 了。
        28
    chaplinj   75 天前
    有问题啊,用不了
        29
    borisxu9824   75 天前
    根据 reddit 上的信息,基本可以确认目前只有 2016 年及以后推出的 Mac 才能用
        30
    sobigfish   74 天前
    @hguandl #12 请问蓝牙版本是? 关于本机》系统报告...》硬件》蓝牙
    还有这些个下面有没有 sidecar 相关的文字 谢谢
    > 支持低功耗蓝牙: 是
    > 支持“接力”: 是
    > 支持智能热点: 是



    勾选了在菜单栏中显示镜像选项(可用时)
    也只是在 iPad 能作为 sidecar 时才会出现图标,不是先有鸡还是先有蛋的问题。
        31
    hguandl   74 天前   ♥ 1
    @sobigfish

    Apple 蓝牙软件版本: 7.0.0d88
    硬件、功能和设置:
    名称: XXX
    地址: XXX
    支持低功耗蓝牙: 是
    支持“接力”: 是
    支持智能热点: 是
    制造商: Broadcom
    传输: USB
    芯片组: 20703A1
    固件版本: v167 c4821
    蓝牙电源: 打开
    可被发现: 关闭
    可连接: 是
    自动寻找点: 打开
    远程唤醒: 打开
    供应商 ID: 0x05AC
    产品 ID: 0x8290
    蓝牙核心规范: 4.2 (0x8)
    HCI 修正版: 0x12D5
    LMP 版本: 4.2 (0x8)
    LMP 子版本: 0x21A7
    设备类型(主要): Computer
    设备类型(完整): Mac Desktop
    复合类设备: 0x380104
    设备类(主要): 0x01
    设备类(次要): 0x01
    服务类: 0x1C0
    自动寻找键盘: 打开

    WiFi:
    卡类型: AirPort Extreme (0x14E4, 0x133)
    固件版本: Broadcom BCM43xx 1.0 (7.77.87.1 AirPortDriverBrcmNIC-1420.2)
    MAC 地址: XXX
    位置: FCC
    国家 /地区代码: US
    支持的 PHY 模式: 802.11 a/b/g/n/ac
    支持的频段: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 144, 149, 153, 157, 161, 165
    无线网络唤醒: 支持
    隔空投送: 支持
    隔空投送频段: 149
    自动解锁: 支持
    状态: 已连接
        32
    sobigfish   74 天前
    看来是蓝牙固件版本的问题,我准备作大 si,Apple 上更新 efi 的软件 看看能不能更新到蓝牙的固件
    https://support.apple.com/downloads/macbook-pro-retina-efi
        33
    sobigfish   74 天前
    原来 efi 已经被系统更新过了 smc 没的升
        34
    arony   74 天前
    "Sidecar 支持 2015 年及后续版本的 MacBook、MacBook Air、MacBook Pro,2015 款及后续的 iMac、2014 款及后续的 Mac mini、以及 2013 年及后续的 Mac Pro 等机型。"
    看来就是这样了
        35
    sobigfish   74 天前
    @arony #34 消息来源是?
    2015 的蓝牙还是 4.0,但 Wi-Fi 802.11ac 2014 款 就有了
        36
    coffish   74 天前   ♥ 1
    来自 reddit:
    https://www.reddit.com/r/apple/comments/bx3eet/sidecar_support_on_older_macs/

    -----
    Edit: To enable unsupported Mac and "display" devices use this Terminal command:

    defaults write com.apple.sidecar.display AllowAllDevices -bool true; defaults write com.apple.sidecar.display hasShownPref -bool true; open /System/Library/PreferencePanes/Sidecar.prefPane

    I had discovered the AllowAllDevices settings before writing this post, but for some reason it did not have effect at first so I resorted to patching the files. Looks like the patching is not needed.

    亲测可用。
    我是 2013 late 的 MBP,一代 iPad pro12.9,都是老机器。
        37
    arony   73 天前
    @coffish 确认有效 但是效果非常差 类似 teamview 等远程桌面这种显示效果
    我的是 mba2013 mid
        38
    zz496   71 天前
    可能是 bug,目测跟 mac 关系比较大。
    初代 iPad Pro 12.9 搭配 Mac mini 2019 可以使用,搭配 Macbook Pro 13 2015 款无法使用。
        39
    nanhezzb   71 天前
    将 iPad 通过数据线连接到 Mac 试下,另外打开蓝牙就可以不通过数据线来投屏了。
        40
    Prophetia   62 天前
    网上找到的强制开启指令,在 MD101 和 iPad Air 2 上成功,条件是登录同一个 AppleID,然后用数据线连接,指令如下:

    defaults write com.apple.sidecar.display AllowAllDevices -bool true; defaults write com.apple.sidecar.display hasShownPref -bool true; open /System/Library/PreferencePanes/Sidecar.prefPane
        41
    Prophetia   61 天前
    @coffish 原来已经有回复了,哈哈,我在其他地方也找到这个办法,确实有效
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1009 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 21ms · UTC 18:33 · PVG 02:33 · LAX 11:33 · JFK 14:33
    ♥ Do have faith in what you're doing.