首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
drawAgirl
V2EX  ›  程序员

xcode 升级到 11 后,'iostream' 等头文件找不到,有解决的吗

  •  
  •   drawAgirl · 99 天前 · 990 次点击
    这是一个创建于 99 天前的主题,其中的信息可能已经有所发展或是发生改变。

    网上搜了很多,没什么解决办法,换成 libc++了也还是报错,但是可以编译成功,command line 卸载重装也试过了,依然没用,现在一堆 error 看着好难受啊。

    4 回复  |  直到 2019-10-14 14:32:40 +08:00
    rsy
        1
    rsy   99 天前 via Android
    你是不是 Xcode 崩溃过一次?我也出现过,按照这个步骤操作就好了。(本人亲自验证过,但不保证适用于所有人,请做好备份工作,否则出现一切后果自负)
    1. 退出 Xcode
    2. 重启电脑
    3. 找到 这个 DerivedData 文件夹 删除 (路径: ~/Library/Developer/Xcode/DerivedData)
    4. 删除这个 com.apple.dt.Xcode 文件 (路径: ~/Library/Caches/com.apple.dt.Xcode)
    5. 运行 Xcode 就好了~~
    vbonluk
        2
    vbonluk   99 天前
    我也遇到了,但是忘记怎么给解决的了。。我还是太垃圾了
    sunhr
        3
    sunhr   99 天前
    如果是 macOS 10.14 的话,可以试一下
    install -pkg /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg
    drawAgirl
        4
    drawAgirl   99 天前
    @rsy 谢谢老哥 我重装了 xcode 好了 如果还出现这样 我再试下
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3680 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 25ms · UTC 06:37 · PVG 14:37 · LAX 22:37 · JFK 01:37
    ♥ Do have faith in what you're doing.