V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
tctc4869
V2EX  ›  Android

android 开发里,如果用 Java 开发考虑兼容性,那么最好选哪个日期框架?

  •  
  •   tctc4869 · 2020-08-24 16:51:54 +08:00 · 1376 次点击
    这是一个创建于 518 天前的主题,其中的信息可能已经有所发展或是发生改变。

    android 开发,想用 java8 里的日期,也就是 localdate,localdate 系列,但测试发型有一个问题,我新买的手机,如果要使用,必须把 minSdkVersion 调高到 26,

    还要在 build.grade 写下这个东西

    compileOptions { sourceCompatibility JavaVersion.VERSION_1_8 targetCompatibility JavaVersion.VERSION_1_8 }

    而我使用了一年多的手机进行调试,调试失败,原因是 minSdkVersion 过高,得把 minSdkVersion 调到 24 左右。但这样的话 java8 的日期在 android 开发里用不了,我真的想骂一句,谷歌的安卓开发框架设计使用体验真差(相对于 Windows 桌面开发),。

    那么如果不用 java8 的日期组件,但又不想直接用简陋的 date,自己封装也费时间,那么有现成的兼容安卓大部分环境的日期框架么?使用体验接近 java8 的日期组件就行,

    14 条回复    2020-08-25 10:22:32 +08:00
    silentt
        1
    silentt  
       2020-08-24 16:59:32 +08:00
    和 java8 类似的时间处理工具可以试试 joda-time
    ifreeky
        3
    ifreeky  
       2020-08-24 17:08:56 +08:00
    joda-time
    gz911122
        4
    gz911122  
       2020-08-24 17:42:24 +08:00
    调到 26 吧...
    kuyuzhiqi
        5
    kuyuzhiqi  
       2020-08-24 18:32:02 +08:00 via iPhone
    一看就是刚进新手村的
    kuyuzhiqi
        6
    kuyuzhiqi  
       2020-08-24 18:33:05 +08:00 via iPhone
    api 没有太多区分,直接从控件角度去思考
    hackerwgf
        7
    hackerwgf  
       2020-08-24 18:35:43 +08:00
    weixiangzhe
        8
    weixiangzhe  
       2020-08-24 18:38:01 +08:00 via Android
    24 国内市场不是不能上架吗
    tctc4869
        9
    tctc4869  
    OP
       2020-08-25 08:55:29 +08:00
    @weixiangzhe 国内市场 app 上架使用的话,最高 api 等级是多高
    weixiangzhe
        10
    weixiangzhe  
       2020-08-25 09:11:54 +08:00
    @tctc4869 我本身不是做 android,不是很记得了,只能说之前做 RN 的时候,依稀记得由于国内权限管理立法后最低 sdk 应该是 26
    tctc4869
        11
    tctc4869  
    OP
       2020-08-25 09:22:40 +08:00
    @weixiangzhe 我去年买的小米 max2,调试 minSdkVersion 26 的 android 项目失败了,无法安装成功,但 7 月份买的小米新手机能调试成功,你知道这是什么回事么()
    unco020511
        12
    unco020511  
       2020-08-25 09:27:45 +08:00
    @hackerwgf #7 +1
    tctc4869
        13
    tctc4869  
    OP
       2020-08-25 09:30:20 +08:00
    @weixiangzhe
    android studio
    调试去年买的小米手机(小米手机 android 7.1.1 api 25 )出现下面信息,
    minsdk api 26 > device api 25
    无法调试,你知道有什么办法么。不然就只能调低 api 了?
    pursuer
        14
    pursuer  
       2020-08-25 10:22:32 +08:00
    @weixiangzhe 应用商店应该是限制 targetSdkVersion 吧,minSdkVersion 通常不会限制
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   3919 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 24ms · UTC 01:38 · PVG 09:38 · LAX 17:38 · JFK 20:38
    ♥ Do have faith in what you're doing.