V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
RickyC
V2EX  ›  PHP

目前看来, TP6 还不能运行在 PHP8, 但是 WordPress5.6 可以

  •  
  •   RickyC · 2020-12-12 09:44:16 +08:00 · 2606 次点击
    这是一个创建于 405 天前的主题,其中的信息可能已经有所发展或是发生改变。
    1. WordPress 5.6 运行在 PHP8.0, 未发现问题
    2. ThinkPHP 6 运行在 PHP8.0 报以下错误 Deprecated: Method ReflectionParameter::getClass() is deprecated
    6 条回复    2020-12-21 22:41:16 +08:00
    dongisking
        1
    dongisking  
       2020-12-12 10:05:59 +08:00 via Android
    这反射的东西也弃用了?😲
    zzw1998
        3
    zzw1998  
       2020-12-12 15:50:18 +08:00 via iPhone
    Laravel 和 Lumen 运行在 PHP8 没问题
    xiaoz
        4
    xiaoz  
       2020-12-12 16:13:05 +08:00 via Android
    慢慢来吧,生产上 8 的话会不会太激进了。
    RickyC
        5
    RickyC  
    OP
       2020-12-14 13:06:29 +08:00
    @xiaoz 也许是的
    topthink
        6
    topthink  
       2020-12-21 22:41:16 +08:00   ❤️ 1
    可以用 TP6 最新的开发版测试 是兼容 PHP8 了的 其实现在生态很多扩展还没跟上的 有点激进 不太建议用于生产
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2482 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 12:06 · PVG 20:06 · LAX 04:06 · JFK 07:06
    ♥ Do have faith in what you're doing.