V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Gloomyer
V2EX  ›  Android

android studio 4.2 纯 Java module 一直报红 但是能正常运行

  •  
  •   Gloomyer · 258 天前 · 908 次点击
    这是一个创建于 258 天前的主题,其中的信息可能已经有所发展或是发生改变。

    今天升级 Android studio 4.2 之后 项目里面有 2 个 module 是 java-library 的 一直报错

    感觉是 jdk 找不到了 改成 android-library 才好

    什么情况?以后 Android Studio 不支持写纯 java 项目了??

    环境:Android Studio4.2

    gradle:4.2.0

    异常配置

    plugins {
    id 'java-library'
    }
    
    dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    }
    
    sourceCompatibility = JavaVersion.VERSION_1_8
    targetCompatibility = JavaVersion.VERSION_1_8
    

    修复后配置

    plugins {
    id 'com.android.library'
    }
    
    dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    }
    
    sourceCompatibility = JavaVersion.VERSION_1_8
    targetCompatibility = JavaVersion.VERSION_1_8
    
    Gloomyer
        1
    Gloomyer  
    OP
       258 天前
    环境:Android Studio4.2

    gradle:4.2.0

    异常配置
    ```
    plugins {
    id 'java-library'
    }

    dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    }

    sourceCompatibility = JavaVersion.VERSION_1_8
    targetCompatibility = JavaVersion.VERSION_1_8
    ```

    修复后配置
    ```
    plugins {
    id 'com.android.library'
    }

    dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    }

    sourceCompatibility = JavaVersion.VERSION_1_8
    targetCompatibility = JavaVersion.VERSION_1_8
    ```
    Gloomyer
        2
    Gloomyer  
    OP
       258 天前
    自己傻逼了,看下了更新说明 project jdk 换成 jdk11 就好了
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1189 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 102ms · UTC 22:57 · PVG 06:57 · LAX 14:57 · JFK 17:57
    ♥ Do have faith in what you're doing.