V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
推荐学习书目
Learn Python the Hard Way
Python Sites
PyPI - Python Package Index
http://diveintopython.org/toc/index.html
Pocoo
值得关注的项目
PyPy
Celery
Jinja2
Read the Docs
gevent
pyenv
virtualenv
Stackless Python
Beautiful Soup
结巴中文分词
Green Unicorn
Sentry
Shovel
Pyflakes
pytest
Python 编程
pep8 Checker
Styles
PEP 8
Google Python Style Guide
Code Style from The Hitchhiker's Guide
vsean
V2EX  ›  Python

M1 芯片 Macbook 无法运行 py 程序,求帮助

  •  
  •   vsean · 45 天前 · 3232 次点击
    这是一个创建于 45 天前的主题,其中的信息可能已经有所发展或是发生改变。
    xcrun: error: unable to load libxcrun (dlopen(/Library/Developer/CommandLineTools/usr/lib/libxcrun.dylib, 0x0005): tried: '/Library/Developer/CommandLineTools/usr/lib/libxcrun.dylib' (mach-o file, but is an incompatible architecture (have 'x86_64', need 'arm64e')), '/usr/lib/libxcrun.dylib' (no such file)).

    有遇到过这种情况的吗?

    希望给予帮助,感谢
    13 条回复    2021-11-02 14:12:47 +08:00
    pkoukk
        1
    pkoukk  
       45 天前   ❤️ 1
    看样子你应该装 arm64 版本的 py ?
    wunonglin
        2
    wunonglin  
       45 天前   ❤️ 1
    装 arm 的 py
    dingwen07
        3
    dingwen07  
       45 天前 via iPhone   ❤️ 1
    你是怎么装的 python,Xcode Command Line Tools 吗,是不是从旧电脑备份还原的?
    0Vincent0Zhang0
        4
    0Vincent0Zhang0  
       45 天前   ❤️ 1
    需要安装 arm64 版本的 py,可以参考 (base64) aHR0cHM6Ly9ibG9nLmNzZG4ubmV0L2hsanNfY29va2Jvb2svYXJ0aWNsZS9kZXRhaWxzLzExMTM5OTYyMQ==
    ysc3839
        5
    ysc3839  
       45 天前   ❤️ 1
    猜测因为 xcrun 是 ARM64 架构的,但是 libxcrun.dylib 是 x86_64 的,所以不兼容。具体什么原因我不知道。
    evejwp
        6
    evejwp  
       45 天前   ❤️ 3
    要仔细看看报错信息:have 'x86_64', need 'arm64e'
    vsean
        7
    vsean  
    OP
       45 天前
    我是先安装了 Miniforge3-MacOSX-arm64.sh 但是没有安装成功,还在找原因,感谢各位
    jeeyong
        8
    jeeyong  
       45 天前   ❤️ 1
    选一个正确的安装方式吧...
    我之前发过一个安装 brew -> pyenv -> python 的记录...
    https://www.v2ex.com/t/739083#reply5
    vsean
        9
    vsean  
    OP
       45 天前
    https://www.python.org/downloads/release/python-391rc1/
    安装完支持 M1 的 python 3.9.1 就可以了,感谢各位的解答
    Drahcir
        10
    Drahcir  
       45 天前
    推荐装个 miniforge 管理 python 环境,支持 m1,方便安装各种库。(用 pip 安装有时会出问题)
    NoAnyLove
        11
    NoAnyLove  
       45 天前
    conda 开始支持 m1 了?
    IgniteWhite
        12
    IgniteWhite  
       44 天前
    huzhikuizainali
        13
    huzhikuizainali  
       34 天前
    @vsean 有个问题,就是如果用一些示例代码学习、练习 python 。这些代码可能是依赖比较老的三方库或者包。那么而在 M1 芯片的 mac 是否会存在无法 import 或者干脆无法安装运行这些老包的问题?
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4154 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 21ms · UTC 02:19 · PVG 10:19 · LAX 18:19 · JFK 21:19
    ♥ Do have faith in what you're doing.