V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
phinney
V2EX  ›  问与答

2022 年,有多少人在用 openSUSE?

  •  
  •   phinney · 87 天前 · 1475 次点击
    这是一个创建于 87 天前的主题,其中的信息可能已经有所发展或是发生改变。

    看网上对 openSUSE 的评价比较两极分化,想问问各位有没有在用 /用过的,体验如何?

    12 条回复    2022-05-16 08:45:05 +08:00
    sky96111
        1
    sky96111  
       87 天前   ❤️ 7
    正在用 openSUSE 风滚草。我说说我对这个发行版的看法。
    我认为的优点:
    1. 友好的安装方式
    2. 强大的 snapper 回滚快照
    3. 背后有商业公司支持,在 bug 反馈上很积极
    4. 滚动式更新,软件包引入更新的速度略慢于 Arch ,快于 Fedora 。
    5. 有内核签名,可以开启 security boot

    下面是我认为的缺点。
    1. zypper 这个包管理器安装应用默认会安装所有可选依赖,但不会自动卸载孤立的依赖,只会在 dist-update 更新的时候,更新中声明了要删除哪个包,zypper 才会去删掉它。
    2. 某些可选依赖的包被列为强依赖。如 tigervnc 被列为 libvart 的强依赖,adobe 等字体被列为 x11 的强依赖,x11 被列为 kde 和 gnome 的强依赖(即使 gnome 和 kde 可以运行在(x)wayland only )
    2. 受限于德国的版权法,多媒体相关的大部分库被移除解码器代码,需要从第三方源补充。因为相关包可能同时存在于官方源和 packman 源中,但行为不一致。导致它们之间配合不是很好,即使设置好优先级,也会偶尔出现切换供应商的时候,官方源比 packman 新,dup 跳过了这个软件。又或者某一天 packman 移除了一个包,zypper 只是报错依赖无法满足,不会引导你切换回官方源
    3. 默认会给你装很多很多你可能用不到的软件:十几个 gnome 的游戏、十几个 kde 的游戏、tigervnc 、一个企鹅图标的 IRC 软件(名字记不清)、libreoffice 等。尽管可以在安装系统时细化选择取消安装,但要 一个一个 取消勾选。而且下一次系统更新的时候可能又会给你装上。。只能卸载后 zypper al(add lock 锁定状态,即当前未安装就不允许自动安装,当前安装了就不允许自动卸载)
    thedrwu
        2
    thedrwu  
       87 天前 via Android
    pidgin 吗? 自从 lunaQQ 挂了以后,聊 qq 聊 msn 都用它
    hdp5252
        3
    hdp5252  
       87 天前 via Android
    用过一段时间,后来换 debian 了
    810244966
        4
    810244966  
       87 天前 via Android
    工行,开的机器全部是 suse 的,没有其他系统的,不过用起来差不多
    wspsxing
        5
    wspsxing  
       87 天前
    openSUSE Tumbleweed 使用三五年了, 挺稳定的,好几个月甚至半年以上滚一次,也不用烦心跨版本升级
    hiplon
        6
    hiplon  
       87 天前
    Oracle Cloud 上有一台
    slrey
        7
    slrey  
       87 天前
    @sky96111 tigervnc 好像用的人还是不少的。我最烦的就是那个 wacom ,完全没法卸载,和整个系统都依赖。。。
    Dart
        8
    Dart  
       87 天前
    银行啊
    Dart
        9
    Dart  
       87 天前
    什么大厂矿啊
    sky96111
        10
    sky96111  
       87 天前 via Android
    @slrey Wacom 是一些设备触控屏和笔的驱动,默认安装我觉得没什么,只是不太符合 KISS 原则
    AlynxZhou
        11
    AlynxZhou  
       86 天前
    > 某些可选依赖的包被列为强依赖。如 tigervnc 被列为 libvart 的强依赖,adobe 等字体被列为 x11 的强依赖,x11 被列为 kde 和 gnome 的强依赖(即使 gnome 和 kde 可以运行在(x)wayland only )

    libvirt (应该是拼错了吧)的显示方式有一个是 vnc ,我估计是开发者自己把这个写成强依赖了,可选依赖需要在代码里检查有没有这个库的,估计是没写。桌面环境不能 drop x11 是因为有些硬件的 wayland 还不太完善。
    tedding
        12
    tedding  
       86 天前 via iPhone
    我我我我我我……
    不过 我有 wacom 数位板……
    tigervnc ui 太复古了。
    依赖问题我随他去了……
    我今天卸载明天 dup 就回来了
    不考虑触摸板加成,mac 对我的吸引越来越小了
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2941 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 32ms · UTC 11:18 · PVG 19:18 · LAX 04:18 · JFK 07:18
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.