V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
xingye163
V2EX  ›  问与答

PVE 突然访问不了 WEB 页面了, SSH 可以链接

  •  
  •   xingye163 · 345 天前 · 2991 次点击
    这是一个创建于 345 天前的主题,其中的信息可能已经有所发展或是发生改变。

    里面安装了爱快和群晖,群晖可以正常访问登录,爱快和 PVE 的 web 端都打不开了,但是连在爱快的网络都正常,爱快的移动 APP 管理也正常,只是单纯的 web 界面打不开,今天因为天气热,想看看服务器里的设备温度是否正常,才发现打不开了。

    试过 HTTPS 和 HTTP 协议,加了端口 8006 和不加都访问不了,手机端可以进去,但是显示是空白,电脑 PC 端,则提示“页面可能存在问题,或者已永久移动到新的网址。”,已经用了半年多了,一直没问题,之前 PVE 里提示软件包升级错误,我查了下好像是没有商业源的许可,但是我这边只要当前版本可以用就可以了,就没管他。

    请问各位大佬有没有遇到过,麻烦教教怎么处理。万分感谢。

    32 条回复    2023-07-08 16:16:10 +08:00
    lddsb
        1
    lddsb  
       345 天前 via iPhone
    重启下 web 服务试试 systemctl restart pveproxy
    xingye163
        2
    xingye163  
    OP
       345 天前
    @lddsb 直接在 SSH 端执行这个命令吗?试了,没有用,还是打不开 web 页面
    rongshan
        3
    rongshan  
       345 天前
    这个可能是个 bug ,我这里也是,偶尔会出现一次,宿主机 WEB 不能访问,个别虚拟机 WEB 不能访问,除此之外,所有网络功能正常,
    重启 pveproxy 无效,
    每次碰到了,我都是整个重启掉
    ochatokori
        4
    ochatokori  
       345 天前 via Android
    curl -v -i http://ip:port
    看看
    ik
        5
    ik  
       345 天前 via iPhone
    你的浏览器是不是版本比较旧? 换个新版本的试试呢
    xingye163
        6
    xingye163  
    OP
       345 天前
    @rongshan 重启整个 PVE 和重启服务都试了,没有用
    xingye163
        7
    xingye163  
    OP
       345 天前
    @ik 最新版的 EDGE 浏览器,使用了手机自带的浏览器和谷歌浏览器都有问题,谷歌浏览器可以进入,但是是空白页面。
    xingye163
        8
    xingye163  
    OP
       345 天前
    @ochatokori 输入后,提示: root@pve:~# 连接主机...
    -bash: 连接主机...: command not found
    ik
        9
    ik  
       345 天前 via iPhone
    @xingye163 我第一次用 pve 的时候是反复重装了好几次,控制台登陆都是白屏, 最后 f12 调试得到一点信息,最后才知道是浏览器版本的问题。供参考
    villivateur
        10
    villivateur  
       345 天前
    你得先明确“打不开”是啥意思,是 http 403 404 502 还是说 tcp reset / timeout 。最好把现象发个图出来,外加日志
    ik
        11
    ik  
       345 天前 via iPhone
    @xingye163 #8 你这是没有 curl 命令,ssh 登陆到 pve 里面执行试试
    kkthy
        12
    kkthy  
       345 天前
    IP 有没有变化?如果变了的话要 ssh 连接改下配置
    Kilerd
        13
    Kilerd  
       345 天前
    我之前也是碰到过这个问题,发生的原因在于装系统的时候添了 IP A ,后来改成了 IP B ,导致 web 界面进不去,好像重启之后就可以了
    xingye163
        14
    xingye163  
    OP
       345 天前
    @ik 我试下,谢谢,因为之前已经正常用了半年多了,也是用的 edge 的这个浏览器访问的
    xingye163
        15
    xingye163  
    OP
       345 天前
    @kkthy 没有改变 IP
    xingye163
        16
    xingye163  
    OP
       345 天前
    @Kilerd 没有重装系统,也没有改变参数,正常使用了半年,突然出现这个情况
    xingye163
        17
    xingye163  
    OP
       345 天前
    @ik 没懂您的意思,我是在 SSH 端口复制您这个命令输入的。
    xingye163
        18
    xingye163  
    OP
       345 天前
    @ik 只是把 IP 改成我的 IP 地址粘贴进去的
    lhbc
        19
    lhbc  
       345 天前 via Android
    OP 这是 Linux 零基础吗
    xingye163
        20
    xingye163  
    OP
       345 天前
    @lhbc 呃,入门都算不上。。。
    titanium98118
        21
    titanium98118  
       345 天前
    linux 零基础,不是应该上 hyper-v?
    ik
        22
    ik  
       345 天前 via iPhone
    @xingye163 #17
    哦哦 我看有段这个, 不知道你是有意改了部分内容,还是确实是贴错了

    -bash: 连接主机...: command not found
    xingye163
        23
    xingye163  
    OP
       345 天前
    @titanium98118 之前用了 ESXi ,可能天气太热还是什么原因,直接卡死,重启镜像都没了,hyper-v 这个没考虑过,主要是稳定使用,推荐的都是 PVE 或者 esxi ,而且这两个系统的教程也比较好找。
    xingye163
        24
    xingye163  
    OP
       345 天前
    @ik 刚看了下,确实是后面的端口没改,我以为是代码,直接就改了 IP ;
    root@pve:~# curl -v -i http://192.168.2.9:8006
    * Trying 192.168.2.9:8006...
    * Connected to 192.168.2.9 (192.168.2.9) port 8006 (#0)
    > GET / HTTP/1.1
    > Host: 192.168.2.9:8006
    > User-Agent: curl/7.74.0
    > Accept: */*
    >
    * Empty reply from server
    * Connection #0 to host 192.168.2.9 left intact
    curl: (52) Empty reply from server
    linuxgo
        25
    linuxgo  
       345 天前
    会不会是硬盘出坏块导致文件系统损坏呢?可以 ssh 登录进去执行这个看看
    sudo badblocks -v /dev/sdax > badsectors.txt
    isnullstring
        26
    isnullstring  
       345 天前
    @xingye163 #23 其实 Windows 普通用用也挺稳的,至少我得 server 2012 已经快两年没重启过,主要是怕重启硬件直接起不来
    xingye163
        27
    xingye163  
    OP
       345 天前
    @linuxgo 谢谢,硬盘确定是没有问题的,其他都是正常的,唯独 web 页面打不开,而且手机浏览器可以登录,但是登录进去是空白的。
    xingye163
        28
    xingye163  
    OP
       345 天前
    @isnullstring 我也是根据网上的 up 主教程弄了个,只求基础功能,稳定就可以了,毕竟折腾这玩意也吃不消,其实要不是闲置了这么一台主机,我直接买个小机器跑爱快最好了,没办法,这个机器性能比较强,单独跑爱快有点浪费了,所以就弄了个群晖放里面,也没啥重要资料。
    vileer
        29
    vileer  
       345 天前 via iPhone
    有改过 pve web 相关的东西吗?我上次刚装完 pve8 好了订阅的 js ,web 就打不开了,具体表现为 web 页面白屏,回滚回来就好了
    xingye163
        30
    xingye163  
    OP
       345 天前
    @vileer 没有改过,突然不能用了,我装好后备份了个镜像,然后就没动过了
    linuxgo
        31
    linuxgo  
       345 天前
    看看系统日志有没有什么线索吧
    isnullstring
        32
    isnullstring  
       344 天前
    @xingye163 #28 哈哈,折腾一下,简单的需求我会尽量用 windows 来做
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   871 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 21:02 · PVG 05:02 · LAX 14:02 · JFK 17:02
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.