V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Aboceder
V2EX  ›  macOS

Homebrew 终于出 GUI 了🎉

  •  
  •   Aboceder · 126 天前 · 31202 次点击
    这是一个创建于 126 天前的主题,其中的信息可能已经有所发展或是发生改变。

    平时用惯了 iterm ,虽然用处不大,但是,好看😄 Github:https://github.com/milanvarady/Applite?tab=readme-ov-file

    第 1 条附言  ·  126 天前
    总的来说,如果是刚刚用 homebrew 的新手的话,比较友好一些,但是对于老登来说,还得是 iterm...
    35 条回复    2024-03-29 19:45:22 +08:00
    loveshuyuan
        1
    loveshuyuan  
       126 天前
    不错,不过好像不是官方出的,我记得以前也有个什么 caskbrew ,但是没这个好看
    Aboceder
        2
    Aboceder  
    OP
       126 天前
    @loveshuyuan 哈哈,主要是好看,caskbrew 太简陋了,功能跟黑窗口无异
    giffgaffman
        3
    giffgaffman  
       126 天前
    好看,用来查看还是很不错的
    YaD2x
        4
    YaD2x  
       126 天前
    好像不支持代理,还是没找到设置的入口
    sky96111
        5
    sky96111  
       126 天前 via Android   ❤️ 1
    这个软件内 app 的图标是怎么来的? cask 配方里没有图标信息吧。还是说他自己维护了元数据
    wangkun025
        6
    wangkun025  
       126 天前
    开发者 18 岁,来自匈牙利。佩服开发者。
    ychen997
        7
    ychen997  
       126 天前 via iPhone
    感谢分享,我之前用过 cakebrew 和 cork ,同时推荐用 alfred 的尝试一下这个
    https://github.com/yinan-c/alfred-homebrew
    tanrenye
        8
    tanrenye  
       126 天前
    那问题来了,这个 UI 可以通过 brew install 吗
    luoling8192
        9
    luoling8192  
       126 天前   ❤️ 1
    AppStore:?
    xenme
        10
    xenme  
       126 天前 via iPhone   ❤️ 2
    @tanrenye 可以,文档有写:
    brew install --cask applite
    holulu
        11
    holulu  
       126 天前
    用了差不多半年了,感觉还好
    Removable
        12
    Removable  
       126 天前 via iPhone
    还挺好用,感谢推荐!
    bjfane
        13
    bjfane  
       126 天前
    brew 没装几个软件,但是还要发帖感谢分享
    littlewing
        14
    littlewing  
       126 天前
    Error: This software does not run on macOS versions older than Ventura.

    我系统太老了
    qgy18
        15
    qgy18  
       126 天前
    挺好用的,感谢推荐
    qgy18
        16
    qgy18  
       126 天前   ❤️ 2
    @sky96111 看了下代码,优先从 https://appfair.app/ 这个项目取 icon ,其次取软件官网 favicon

    ```
    appIconView(iconURL: URL(string: "https://github.com/App-Fair/appcasks/releases/download/cask-\(cask.id)/AppIcon.png")!,
    faviconURL: URL(string: "https://icon.horse/icon/\(cask.homepageURL.host ?? "")")!)
    ```
    qgy18
        17
    qgy18  
       126 天前
    @qgy18 像 Arc 浏览器,appfair 和 icon horse 都没取到图标,只好用字符兜底。
    y1y1
        18
    y1y1  
       126 天前
    体验了下,感觉图标不太好看
    kenniewwwww
        19
    kenniewwwww  
       126 天前
    montery 还没法体验……
    shinsekai
        20
    shinsekai  
       126 天前
    这个 GUI 好像只能装带 GUI 的 app ,ffmpeg 之类的不能安装,管理
    Aboceder
        21
    Aboceder  
    OP
       126 天前
    @ychen997 哈哈哈,我用的 raycast ,也有类似的插件
    @luoling8192 抢生意😂,其实也就是图个好看的 ui ,对实际使用帮助不大
    @shinsekai 确实,诸如 mysql ,redis ,node 这种常见的开发工具,都没有
    @littlewing @kenniewwwww 如果是老登,那就不必遗憾了,因为对老登来说没啥用,啊哈哈哈
    kiritoyui
        22
    kiritoyui  
       126 天前
    我寻思着这也不是新项目啊,怎么就终于有 GUI 了,早就有了好吧
    Aboceder
        23
    Aboceder  
    OP
       126 天前
    @kiritoyui such as ?
    tsohgdivil
        24
    tsohgdivil  
       126 天前
    @shinsekai #20 不是带 GUI 的 APP ,是只能安装 brew cask 源里面的应用
    steveshi
        25
    steveshi  
       126 天前
    cork 不就很好用么,就是需要自己编译罢了
    morizawatt
        26
    morizawatt  
       126 天前
    哦莫,这 icon 大阴影😂

    gesse
        27
    gesse  
       126 天前
    6i3BMhWCpKaXhqQi
        28
    6i3BMhWCpKaXhqQi  
       126 天前
    brew tap buo/cask-upgrade
    brew cu -ay --no-quarantine
    brew upgrade --no-quarantine
    brew cleanup --prune=all
    Aboceder
        29
    Aboceder  
    OP
       125 天前
    @morizawatt icon 确实丑,😂
    houshuu
        30
    houshuu  
       125 天前 via iPhone
    还是 cli 快,感觉缺的是那种类似于 suse yast 那样的可以在安装前可以预览下依赖的工具。有时候只想安一个结果安上一大堆,还不如官网下个二进制方便
    NouveauNom
        31
    NouveauNom  
       125 天前
    这个东西看不到,本地已经安装的库吗
    Aboceder
        32
    Aboceder  
    OP
       124 天前
    @houshuu 确实依赖问题是 brew 的痛点,杂乱且不好管理
    winnie2012
        33
    winnie2012  
       119 天前
    现在好多软件要求最低 macOS 13+,我的 macbook 2015 安装不上。
    Aboceder
        34
    Aboceder  
    OP
       118 天前
    @winnie2012 因为开发者懒得做兼容
    jqtmviyu
        35
    jqtmviyu  
       115 天前
    @houshuu #30 想起被 ffmpeg 支配的恐惧😭, 最后还是下二进制丢 bin 目录
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   5454 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 29ms · UTC 06:12 · PVG 14:12 · LAX 23:12 · JFK 02:12
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.